ซีเอ็ดบุ๊คเซ็นเตอร์
อันดับหนังสือขายดี
เว็บบอร์ด

เปิดโลกเครือข่าย CISCO ตอนหลักการทำงานและติดตั้ง Router ภายใต้ Routing Protocol

ดร.วิรินทร์ เมฆประดิษฐสิน

การทำงานของ Router  / การจัดวางตำแหน่งของ Router / ความแตกต่างระหว่างการเชื่อมเครือข่ายด้วย Layer 3 Switches กับ Router ในรูปแบบ Server / การติดตั้ง Router บน WAN / รูปลักษณะการเชื่อมต่อ (Topology) / โปรโตคอลเลือกเส้นทาง (Routing Protocol) / โปรโตคอลเลือกเส้นทางคืออะไร ?  / รู้จักกับ Routing Information Protocol (RIP) / การเกิดปัญหา Routing Loop / การติดตั้งและจัด Configure RIP ขั้นพื้นฐาน / ส่งท้ายบทความ

Router ที่ใช้เพื่อการเชื่อมต่อระหว่างเครือข่ายผ่านทาง WAN หรือโครงข่ายสาธารณะ อย่าง เช่นผ่านทางเฟรมรีเลย์ หรือ ISDN หรือ การเช่าคู่สาย 64K ขึ้นไป เราเรียกว่า WAN Router

สวัสดีท่านผู้อ่านและลูกศิษย์ที่รักทุกท่าน ฉบับนี้ผู้เขียนขอเสนอบทความเกี่ยวกับหลักการทำงานและติดตั้ง Router ของ Cisco รวมทั้งวิธีการออกแบบและบริหารจัดการ Router ภายใต้ Routing Protocol ต่างๆ ซึ่งผู้เขียนหวังใจว่า ทุกท่านจะได้รับประโยชน์ไม่มากก็น้อย

กลับด้านบน

การทำงานของ Router

Router เป็นอุปกรณ์ที่ถูกนำมาใช้เพื่อการเชื่อมต่อระหว่างเครือข่าย ไม่ว่าจะเป็นการเชื่อมต่อระหว่างเครือข่ายที่ใช้คนละ Class ของไอพี เช่น การเชื่อมต่อระหว่าง เครือข่าย ที่มีไอพีแอดเดรสเบอร์ 192.168.20.0 กับเครือข่ายที่มีไอพีแอดเดรส 192.168.30.0 เป็นต้น รวมทั้งการเชื่อมต่อเครือข่ายย่อย (เครือข่ายเดียวกันแต่ถูกแบ่งออกเป็นส่วนย่อยๆ เช่น แบ่งเครือข่ายที่มีหมายเลขไอพีแอดเดรส 192.168.30.0 ออกเป็นเครือข่ายย่อยๆ (Subnet) จำนวน 6 เครือข่าย จากนั้นนำมาเชื่อมต่อกัน เพื่อการสื่อสารกันด้วย Router

Router เป็นอุปกรณ์เชื่อมต่อเครือข่ายในระดับชั้น Network ตามมาตรฐานของ OSI Model หน้าที่หลักของ Router ได้แก่ การอ้างอิงไอพีแอดเดรสระหว่างเครื่องลูกข่ายที่อยู่กันคนละเครือข่าย รวมทั้งการเลือกและจัดเส้นทางที่ดีที่สุด เพื่อนำข้อมูลข่าวสาร ในรูปแบบของแพ็กเกจจากเครื่องลูกข่ายต้นทางบนเครือข่ายที่ตนดูแลอยู่ไปยังเครื่องลูกข่ายที่อยู่กันคนละเครือข่าย

Router ที่ใช้เพื่อการเชื่อมต่อระหว่างเครือข่ายผ่านทาง WAN หรือโครงข่ายสาธารณะ อย่าง เช่นผ่านทางเฟรมรีเลย์ หรือ ISDN หรือ การเช่าคู่สาย 64K ขึ้นไป เราเรียกว่า WAN Router ส่วน Router ที่ใช้เชื่อมต่อระหว่างเครือข่ายชนิดติดตั้งบนแลนและเชื่อมต่อระหว่างเครือข่ายด้วยสายสัญญาณของระบบแลน เราเรียกว่า Local Router หรือบางครั้งจะถูกเรียกว่า Internal Router ซึ่ง Router ประเภทนี้อาจเป็น Router ในรูปแบบผลิตภัณฑ์ Router เต็มตัว หรือแบบที่มีการติดตั้งการ์ดแลนหลายชุดบนเครื่องคอมพิวเตอร์ที่ติดตั้งเซิร์ฟเวอร์เป็นต้น

กลับด้านบน

การจัดวางตำแหน่งของ Router

กฎกติกาขั้นพื้นฐานของ การจัดวาง Router ที่เชื่อมต่อกันบน WAN ได้แก่ กฎกติกาการไหลของข้อมูลข่าวสารแบบ 80/20 % ซึ่งในที่นี้ หมายความว่า 80% ของข้อมูลข่าวสารที่จะสื่อสารกัน จะต้องเกิดขึ้นภายในเครือข่าย เดียวกัน จะต้องไม่ข้ามออกไปทาง Router มิเช่นนั้น เครือข่ายจะทำงานช้าอย่างเห็นได้ชัด ส่วน 20% หมายถึง ปริมาณของข้อมูลข่าวสารที่จะข้ามไปมาระหว่างเครือข่าย

แต่ในกรณีที่มีเครือข่าย หลายเครือข่ายติดตั้งอยู่ในพื้นที่เดียวกัน และต้องการเชื่อมต่อเพื่อสื่อสารระหว่างกัน ท่านจะต้องพิจารณาใช้ Switching Hub แบบ Layer 3 หรือ พิจารณาเพื่อติดตั้ง Router ในรูปแบบของเซิร์ฟเวอร์นั่นคือการติดตั้งการ์ดแลนหลายชุดบนเครื่องเซิร์ฟเวอร์นั่นเอง

กลับด้านบน

ความแตกต่างระหว่างการเชื่อมเครือข่ายด้วย Layer 3 Switches กับ Router ในรูปแบบ Server

ในกรณีที่เครือข่ายต่าง ๆ ติดตั้งอยู่ในพื้นที่เดียวกัน ท่านจะต้องพิจารณาเลือกใช้ Local หรือ Internal Router ส่วนจะเลือกใช้ Local Router ในรูปแบบใด ให้พิจารณาปัจจัยต่าง ๆ ดังนี้

  •  ระยะทางการเชื่อมต่อระหว่าง เครือข่าย (แม้จะอยู่ในอาณาบริเวณเดียวกัน หรือใกล้กันก็ตาม)
  •  อัตราความเร็วที่ต้องการ
  •  ประเภทของสื่อสัญญาณ (สายสัญญาณ) ที่ใช้
  •  โปรโตคอลการสื่อสารระหว่างเครือข่าย โปรโตคอลของแลนที่นำมาเชื่อมต่อระหว่างกัน
  •  ปริมาณและขนาดความซับซ้อนของเครือข่าย
  •  ปริมาณของข้อมูลข่าวสารที่วิ่งไปมาระหว่างเครือข่าย
  •  รูปแบบการเชื่อมต่อ (Topology) ของเครือข่าย
  •  โปรโตคอลเลือกเส้นทาง (Routing Protocol) ที่จะนำมาใช้

ระยะทางการเชื่อมต่อระหว่างเครือข่าย

หากระยะทางการเชื่อมต่อระหว่างเครือข่าย มีไม่เกิน 200 เมตร ท่านควรใช้ Router ที่ทำจาก Server เนื่องจากว่าราคาถูก อีกทั้งสามารถเชื่อมต่อกันได้ โดยใช้สาย UTP (ดูรูปที่ 1)

รูปที่ 1 แสดงลักษณะของ Router ที่ทำงานบน Server ภายใต้ Windows NT/2000 Server หรือ LINUX

อัตราความเร็วที่ต้องการ

อัตราความเร็วในที่นี้ หมายถึงความเร็วของการเชื่อมต่อระหว่างเครือข่ายในระดับของข้อมูลข่าวสาร โดยคิดอัตราเมกกะบิตต่อวินาที หรือที่เรียกว่าค่า Throughput โดยหากเครือข่ายที่เชื่อมต่อระหว่างกันมีเพียง 2 เครือข่าย อีกทั้งปริมาณข้อมูลข่าวสารมีขนาดเล็กหรือปานกลางวิ่งที่ความเร็วไม่เกิน 100 Mbps และมีราคาถูก ท่านควรเลือกใช้ Router ที่ทำจากเซิร์ฟเวอร์เช่นกัน แต่หากปริมาณของข้อมูลข่าวสารวิ่งข้ามไปมาระหว่างเครือข่ายมีมาก (มากในระดับ 80% ขึ้นไป) ท่านควรพิจารณาเลือกใช้ความเร็วระดับ Gigabit โดยติดตั้งการ์ดแลนทั้งสองบนเครื่องเซิร์ฟเวอร์ และเชื่อมต่อเข้ากับ Switches Hub ที่ติดตั้ง Gigabit Modules ทั้ง 2 ด้านบนเครือข่าย ดังรูปที่ 2

รูปที่ 2 แสดงลักษณะการเชื่อมต่อ Router ที่ทำจาก Server ชนิดที่รองรับ ปริมาณข้อมูลได้มาก

ในกรณีที่ท่านต้องการเชื่อมต่อเครือข่ายมากกว่า 2 เครือข่ายขึ้นไป ท่านควรพิจารณาเลือกใช้ Layer 3 Switching Hub แทน เนื่องจากอัตราความเร็ว รวมทั้งปริมาณของข้อมูลข่าวสารที่ข้ามไปมาหลายเครือข่ายสามารถทำได้อย่างรวดเร็วและมีประสิทธิภาพ ตัวอย่างเช่น Layer 3 Switching Hub โดยทั่วไปหากวิ่งที่ 100 Mbps แต่ละพอร์ตของ Switches จะสามารถส่งผ่านข้อมูลในรูปแบบของเฟรมได้มากถึง 148,000 เฟรมต่อวินาที โดยหากเทียบกันกับ Router ที่ทำจากเซิร์ฟเวอร์แล้ว Layer 3 Switching จะเร็วกว่ากันมาก ดังรูปที่ 3

รูปที่ 3 แสดงลักษณะการใช้งาน Layer 3 Switching Hub

Cisco มีผลิตภัณฑ์ ที่เป็น Switching Hub แบบ Layer 3 หลายรุ่น ได้แก่ Catalyst 4908G-L3 เป็นต้น

ประเภทของสื่อสัญญาณที่ใช้

สื่อสัญญาณที่ใช้เป็นตัวบ่งบอกถึงข้อจำกัดของการเชื่อมต่อเครือข่าย ในกรณีที่ท่านใช้ Router ที่ทำจากเซิร์ฟเวอร์และใช้การ์ดแลนแบบ 100Base-FX ซึ่งใช้สาย Fiber Optic แบบ 2 Core (2 Strand) ขนาด 62.5/125 ความยาวคลื่นขนาด 850 nm ท่านสามารถเชื่อมต่อได้ระยะทาง 412 เมตร ต่อ 1 ด้าน (ดูรูปที่ 4)

รูปที่ 4 แสดงระยะทางการเชื่อมต่อกันระหว่าง Switching Hub บนเครือข่าย กับ Router

ในกรณีที่ท่านใช้ Layer 3 Switches Hub และเป็นระบบ 100Base-FX ท่านสามารถเชื่อมต่อกับเครือข่ายต่างๆ หลาย ๆ เครือข่ายเข้าด้วยกัน โดยมีระยะทางการเชื่อมต่อระหว่างเครือข่ายที่ต่างก็ใช้ Switching Hub มาเชื่อมต่อกับเครือข่าย ได้ไกลถึง 2 กิโลเมตร (หากกำหนดให้ Switches ทั้งหมดทำงานเป็น Full Duplex) ดูรูปที่ 5

รูปที่ 5 แสดงลักษณะการเชื่อมต่อและระยะทางการเชื่อมต่อระหว่างเครือข่ายต่างๆ ผ่านทาง Layer 3 Switches

แต่หากท่านใช้ Layer 3 Switching Hub แบบ Gigabit 1000Base-LX ท่านจะได้ระยะทาง 6000 เมตร ขึ้นไปจนถึง 10 กิโลเมตร ด้วยการกำหนดให้ Switches ทำงานแบบ Full Duplex เช่นกัน สายสัญญาณที่ใช้ ได้แก่ สาย Fiber Optic แบบ Single Mode ขนาดความยาวคลื่น 1310 nm

โปรโตคอลการสื่อสารระหว่างเครือข่าย

โปรโตคอลการสื่อสารระหว่างเครือข่ายในที่นี้ เป็นโปรโตคอล การทำงานในระดับชั้น Network ได้แก่ TCP/IP หรือ IPX รวมทั้ง AppleTalk

โปรโตคอล TCP/IP สามารถเอื้ออำนวยให้ Router ที่ทำจากเซิร์ฟเวอร์ใช้กลไกการ ทำงานของ Routing ที่มีอยู่ (Routing Daemon) เพื่อการส่งผ่านข้อมูลข่าวสารระหว่างเครือข่ายได้โดยง่าย นอกจากนี้ Router ที่ทำจาก Server ยังสามารถใช้งานโปรโตคอล IPX ได้ดี ภายใต้ ระบบปฏิบัติการ Novell Netware

โปรโตคอลของ LAN ที่นำมาเชื่อมต่อกัน

ในกรณีที่ท่านใช้ Switches Hub แบบ Layer 3 ข้อจำกัดของท่านคือ ท่านสามารถใช้ได้เฉพาะระบบอีเทอร์เน็ตเท่านั้น เนื่องจากปัจจุบันผู้ผลิตต่างก็ผลิต Switches Hub Layer 3 ที่สนับสนุนระบบอีเทอร์เน็ตเท่านั้น และในกรณีที่ท่านใช้ Router ที่ทำจากเซิร์ฟเวอร์ ท่านสามารถใช้โปรโตคอลของระบบแลนได้หลายแบบ เช่น ระบบ Ethernet LAN ระบบ Token Ring LAN รวมทั้ง AppleTalk แต่มีข้อแม้ว่าโปรโตคอลในระดับชั้นเครือข่าย (Network Layer Protocol) จะต้องเป็นแบบ TCP/IP หรือ IPX

ปริมาณและขนาดความซับซ้อนของเครือข่าย

สำหรับเครือข่ายขนาดเล็กที่มีจำนวนเครื่องลูกข่ายไม่มาก อีกทั้งจำนวนเครือข่ายที่มาเชื่อมต่อกัน มีเพียง 2 หรือ 3 ท่านสามารถใช้ Router ที่ทำจากเซิร์ฟเวอร์ได้โดยไม่มีผลกระทบต่อประสิทธิภาพ มากนัก แต่ในกรณีที่มีหลายๆเครือข่ายเช่น 3-4 เครือข่ายขึ้นไป อีกทั้งมีขนาดใหญ่ (ปริมาณเครื่องลูกข่ายในแต่ละเครือข่ายมีมาก) การใช้ Router ที่ทำจากเซิร์ฟเวอร์จะทำให้เซิร์ฟเวอร์นี้ทำงานหนักมาก และอาจเกิดคอขวดส่งผลให้ประสิทธิภาพลดลง ควรพิจารณาเลือกใช้ Layer 3 Switches แทน

  หมายเหตุ : ข้อแตกต่างประการหนึ่งระหว่าง Layer 3 Switches กับ Router ที่ทำจาก Server ที่เห็นได้อย่างชัดเจนคือ Router ที่ทำจาก Server เหมาะสำหรับ ปริมาณของข้อมูลข่าวสารที่วิ่งข้ามไปมาระหว่างเครือข่าย จะต้องมีไม่เกิน 20% เท่านั้น โดยที่การสื่อสารที่เกิดขึ้น 80% เป็นของภายในเครือข่าย แต่สำหรับ Switches แบบ Layer 3 เหมาะสำหรับ การสื่อสารข้อมูลที่วิ่งข้ามไปมาระหว่างเครือข่าย 80% อีก 20% เป็นการสื่อสารภายใน รวมทั้ง สนับสนุนการสื่อสารแบบ 80% เป็นภายในเครือข่าย และ 20% แบบออกนอกเครือข่าย เช่นเดียวกับ Router ที่ทำจาก Server ได้อีกด้วย

ปริมาณของข้อมูลที่วิ่งไปมาระหว่างเครือข่าย

หากปริมาณของข้อมูลที่วิ่งไปมาระหว่างเครือข่าย มีมาก และต้องการความเร็วสูง การใช้ Layer 3 Switches เป็นทางออกที่ดีกว่าการใช้ Route ที่ทำจากเซิร์ฟเวอร์

รูปแบบการเชื่อมต่อของเครือข่าย

การใช้ Router ที่ทำจากเซิร์ฟเวอร์จะทำให้เกิดข้อจำกัดในรูปแบบการเชื่อมต่อ โดยมีรูปแบบการเชื่อมต่อระหว่างจุด (Point To Point) ระหว่างเครือข่ายกับ Router และ ระหว่าง Router กับเครือข่ายอีกฟากหนึ่ง อีกทั้งระยะทางที่จำกัด การใช้ Layer 3 Switches เหมาะสำหรับเครือข่ายขนาดใหญ่ ที่มีเครือข่าย มากมาย กระจายไปตามจุดหรืออาคารต่างๆขององค์กร โดยมีลักษณะการเชื่อมต่อแบบ Collapse back Bone (ดูรูปที่ 5)

โปรโตคอลเลือกเส้นทาง (Routing Protocol) ที่จะนำมาใช้

เช่นเดียวกับ Router ที่ทำงานบน WAN ตัว Layer 3 Switches Hub ให้การสนับสนุนโปรโตคอลเลือกเส้นทาง มากมายหลายแบบ (แต่จะมีความหลากหลายน้อยกว่า) เช่น ให้การสนับสนุนโปรโตคอลเลือกเส้นทางแบบ RIP Version 1 หรือ 2 รวมทั้ง OSPF (Open Short Path First) อย่างไรก็ดี Router ที่ทำจาก Windows 2000 Server ก็สามารถใช้ RIP และ OSPF ได้เช่นกัน แต่ประสิทธิภาพการทำงานด้อยกว่า

กลับด้านบน

การติดตั้ง Router บน WAN

การติดตั้ง Router บน WAN จะต้องพิจารณาปัจจัย ดังนี้

  •  รูปลักษณะของการเชื่อมต่อ (Topology)
  •  ขนาดและจำนวนของเครือข่าย
  •  รูปแบบของการเชื่อมต่อระหว่างเครือข่าย

กลับด้านบน

รูปลักษณะการเชื่อมต่อ (Topology)

รูปลักษณะการเชื่อมต่อของ Router ผ่าน WAN มีอยู่หลายรูปแบบ ดังนี้

1. แบบ Point To Point หรือระหว่างจุด

2. แบบ Hub and Spoke (รูปแบบ Star)

3. แบบ Serial Bus

4. แบบ Loop ปิด

5. แบบ Mesh ซึ่งประกอบด้วย Semi หรือ Partial Mesh และ Fully Mesh

6. แบบผสม หรือ Hybrid

7. แบบ ระดับขั้น (Hierarchical)0

แบบ Point To Point

เป็นรูปแบบการเชื่อมต่อเครือข่ายที่เรียบง่ายที่สุด โดยท่านอาจมี 2 เครือข่าย เช่น เครือข่ายบริษัทแม่ และสาขา มาเชื่อมต่อกัน เป็นต้น

รูปที่ 6 แสดงการเชื่อมต่อของ Router แบบ จุดต่อจุด (Point To Point)

รูปแบบการเชื่อมต่อแบบนี้ท่านไม่จำเป็นต้องใช้โปรโตคอลเลือกเส้นทาง (Routing Protocol) แต่ท่านสามารถใช้ วิธีการ Routing แบบ ที่เรียกว่า Static แทน ซึ่งวิธีนี้ มีประสิทธิภาพดีกว่าการใช้โปรโตคอลเลือกเส้นทาง อีกทั้ง Router ที่ใช้มีขนาดเล็ก ราคาถูก ติดตั้งง่าย สนับสนุนการสื่อสารทั้งแบบ Voice และ Data การเชื่อมต่อเรียบง่ายใช้การเช่าคู่สาย (Leased Line) ขนาด 64K ก็เพียงพอแล้ว

แบบ Hub and Spoke

การเชื่อมต่อ Hub and Spoke เหมาะสำหรับท่านที่มีเครือข่ายมากกว่า 2 เครือข่ายขึ้นไป มาเชื่อมต่อกันแบบ ค่าใช้จ่ายต่ำ เนื่องจากจำนวนช่องสัญญาณการเชื่อมต่อกันมีเพียง 1 ช่องทาง อย่างไรก็ดีการเชื่อมต่อแบบนี้มีจุดอ่อนตรงที่การไม่มีช่องสัญญาณทดแทนทันที (Redundant Link) หากช่องสัญญาณเกิดความผิดพลาด ก็จะทำให้ Router หลุดออกจากเครือข่ายทันที นอกจากนี้ Router ที่ทำหน้าที่เป็น Hub (Router A) ที่ติดตั้งทางกรุงเทพ (ดูรูปที่ 7) จะต้องมีขนาดใหญ่ มีประสิทธิภาพของซีพียูสูง มีหน่วยความจำที่จะใช้เป็นบัฟเฟอร์มากกว่า Router ที่ทำหน้าที่เป็น Spoke ซึ่งใช้ Router ขนาดเล็กราคาถูก อีกทั้งต้องมีพอร์ตเพื่อเชื่อมต่อกับ Router ต่าง ๆ เป็นจำนวนมาก เท่ากับจำนวนของ Router แบบ Spoke

รูปที่ 7 แสดงลักษณะการเชื่อมต่อแบบ Hub and Spoke

โปรโตคอลเลือกเส้นทาง ที่จะนำมาใช้กับรูปแบบการเชื่อมต่อแบบ Hub and Spoke นี้ ควรเป็นแบบ Static เนื่องจาก Router แต่ละตัวมีเส้นทางการเชื่อมต่อเพียงเส้นทางเดียว และวิ่งผ่าน Hub ดังนั้น จึงไม่จำเป็นต้องใช้ โปรโตคอลเลือกเส้นทางแต่อย่างใด เนื่องจาก ไม่มีเส้นทางอื่นให้เลือกนั่นเอง

แบบ Serial Bus

แบบ Serial Bus เหมาะสำหรับการเชื่อมต่อระหว่าง Router ที่อยู่ห่างไกลกันมาก ที่มีปัญหาเรื่องค่าใช้จ่าย อีกทั้งปริมาณของการสื่อสารข้อมูลมีไม่มาก และไม่ห่วงเรื่องของ Delay ที่อาจเกิดขึ้นการเชื่อมต่อแบบ Serial Bus จะทำให้ Router แต่ละจุดอาศัยซึ่งกันและกันในการส่งผ่านข้อมูลระหว่างเครือข่าย โดยแต่ละจุดจะจ่ายค่าเชื่อมต่อเฉพาะตน ดังนั้นจึงดูเหมือนเป็นลักษณะการแบ่งการออกค่าใช้จ่ายระหว่างกัน (ดูรูปที่ 8) Router ที่จะนำมาเชื่อมต่อแบบ Serial Bus นี้ จะต้องมี Port ที่ใช้เชื่อมต่อกับ WAN อย่างน้อย 2 ชุด

ข้อเสียของระบบ Serial Bus มีหลายประการ ได้แก่ การเกิด Delay ค่อนข้างมาก เนื่องจาก Router แต่ละตัวจะต้องส่งผ่านข้อมูลไปหาเครือข่ายปลายทางที่อาจผ่าน Router หลายๆตัว ทำให้จำนวนครั้งของการกระโดดข้ามผ่านกัน (Hop) มีมาก ซึ่งท่านสามารถใช้คำสั่ง Tracert บน Windows หรือ Traceroute บน UNIX หรือ LINUX เพื่อตรวจสอบค่า Delay ที่เกิดขึ้นได้ นอกจากนี้ ยังมีปัญหาเรื่อง Redundant โดยหากมี Router ตัวใดตัวหนึ่งเกิดทำงานผิดพลาด ก็เสมือนกับสะพานเชื่อมโยงไปมาระหว่างกัน เกิดขาดสะบั้น

อนึ่ง ท่านไม่จำเป็นต้องใช้โปรโตคอลเลือกเส้นทาง โดยสามารถใช้ Static Route จะดีกว่า เพราะสามารถตัดปัญหาเรื่อง Delay ที่จะเกิดขึ้นเนื่องจากใช้ โปรโตคอลเลือกเส้นทาง

รูปที่ 8 แสดงลักษณะการเชื่อมต่อแบบ Serial Bus

การเชื่อมต่อแบบ Loop ปิด

การเชื่อมต่อแบบ Loop ปิด เป็นการเชื่อมต่อที่มีด้านปลายด้านใดด้านหนึ่งเชื่อมต่อกับปลายของอีกด้านหนึ่ง ข้อดีของการเชื่อมต่อแบบนี้อยู่ที่การมี Redundant หากเส้นทางการเชื่อมต่อจุดใดจุดหนึ่งเกิดขาดก็ยังสามารถเชื่อมต่ออันได้โดยอัตโนมัติ นอกจากนี้ท่านยังสามารถเลือกใช้โปรโตคอลเลือกเส้นทางอีกด้วย อย่างไรก็ดีการใช้ โปรโตคอลที่มีประสิทธิภาพด้อย อาจทำให้เกิดปัญหาที่เรียกว่า Routing Loop ซึ่งจะได้กล่าวถึงต่อไป

รูปที่ 9 แสดงรูปแบบการเชื่อมต่อแบบ Loop ปิด

การเชื่อมต่อแบบ Mesh

การเชื่อมต่อแบบ Mesh เป็นรูปแบบการเชื่อมต่อที่เน้นจำนวนของช่องสัญญาณการเชื่อมต่อระหว่างกันหลายช่องทาง ซึ่งจะช่วยให้โปรโตคอลเลือกเส้นทาง สามารถทำงานได้อย่างมีประสิทธิภาพท่ามกลางขีดความสามารถในเรื่องของ Redundant

การเชื่อมต่อแบบ Mesh สามารถมีได้ 2 รูปแบบ ได้แก่ แบบ Partial หรือ Semi Mesh และแบบ Full Mesh

การเชื่อมต่อทั้งสองแบบต่างกันตรงที่จำนวนของช่องสัญญาณ ที่เชื่อมต่อระหว่างกัน นั้นแบบ Fully Mesh จะมีมากกว่า ทั้งสองแบบ ต่างก็ต้องการโปรโตคอลเลือกเส้นทางที่มีประสิทธิภาพสูง

รูปที่ 10 การเชื่อมต่อแบบ Partial Mesh (บน) และการเชื่อมต่อแบบ Fully Mesh (ล่าง)

การเชื่อมต่อแบบผสม หรือHybrid

การเชื่อมต่อแบบผสมหมายถึงการผสมกันระหว่างรูปแบบต่างๆ เช่น แบบ Hub and Spoke กับ Loop เป็นต้น การเลือกใช้รูปแบบนี้ขึ้นอยู่กับระยะทาง ค่าใช้จ่าย หรือ ความปลอดภัย และ Redundant มาประกอบกัน

การเชื่อมต่อแบบลำดับขั้น (Hierarchical)

การเชื่อมต่อแบบนี้ เหมาะสำหรับเครือข่ายขนาดใหญ่ ที่อาจแบ่งออกเป็นกลุ่มของเครือข่าย ในระดับภูมิภาค หลายๆกลุ่มมาเชื่อมโยงกัน โดยใช้โปรโตคอลเลือกเส้นทางที่มีประสิทธิภาพสูง อย่างเช่น OSPF รวมทั้ง Router ที่จะนำมาใช้ มีระดับขีดความสามารถที่แตกต่างกัน ซึ่งได้มีกรกำหนดระดับขั้นของ Router บนเครือข่ายประเภทนี้ อยู่ 3 แบบ ดังนี้

  •  แบบ ระดับชั้น Access
  •  แบบระดับชั้น Distributor
  •  แบบระดับชั้น Core หรือ Back Bone

รูปที่ 11 แสดงลักษณะการเชื่อมต่อ Router แบบ ลำดับขั้น

ระดับชั้น Access

ในระดับชั้น Access นี้ Router จะเชื่อมโดยตรงกับเครือข่าย โดยคอมพิวเตอร์ลูกข่ายจะอาศัย Router ในระดับขั้นนี้เพื่อการติดต่อกับเครือข่ายภายนอก Router ที่ทำงานในระดับนี้ เป็น Router ขนาดเล็กมีความเร็วในการทำงานของ CPU รวมทั้ง หน่วยความจำที่จะนำมาใช้เป็นบัฟเฟอร์ไม่มากนัก ส่วนพอร์ตที่เชื่อมต่อกับเครือข่ายแลนอาจมี 1-2 พอร์ต ก็ได้ แต่สำหรับ WAN Port จะมีอย่างน้อย 2 พอร์ต ขึ้นไป

ระดับชั้น Distributor

Router ในระดับนี้ มักเป็น Router ขนาดกลาง ที่อาจมีพอร์ตที่เชื่อมต่อกับ Router ในระดับ Access มากกว่า 4 พอร์ตขึ้นไป Router ในระดับนี้ บางรุ่น อาจมี Port เชื่อมต่อกับ WAN มากถึง 16 พอร์ต หรืออาจมีมากกว่านั้น ที่สำคัญ Router จะต้องมีซีพียูความเร็วสูง โดยอาจมีความเร็วเกินกว่า 120 MHz ขึ้นไป รวมทั้งมีบัฟเฟอร์เป็นจำนวนมากเพื่อใช้เก็บตารางเส้นทาง (Routing Table) ขนาดใหญ่

ระดับชั้น Core

Core Router มีลักษณะที่โดดเด่นกว่า Router ในระดับอื่นๆ ตรงที่ เป็น Router แบบ Multi-Layer Multi-protocol ที่สามารถสนับสนุน การเชื่อมต่อรูปแบบต่างๆ ได้มากมาย สามารถเชื่อมต่อกับ Core Router อื่นๆ ผ่านทาง ATM ก็ได้ Router ระดับ Core นี้บางครั้งถูกเรียกว่า Back Bone Router เป็น Router ที่เชื่อมต่อกับกลุ่มของ Distributed Router จำนวนหนึ่ง

กลับด้านบน

โปรโตคอลเลือกเส้นทาง (Routing Protocol)

หัวใจสำคัญในการทำงานของ Router ได้แก่ การเลือกเส้นทาง และวิธีการเลือกเส้นทาง ก็อาศัยการคำนวณโดยใช้ค่าที่ได้มาจากการสำรวจ รวมทั้งตัวแปรมาตรฐานที่มีอยู่ นำมาใช้เพื่อการคำนวณ เส้นทาง ที่ดีที่สุดที่จะนำพา Packet ไปที่ปลายทาง สำหรับ Router ที่เชื่อมต่อกันแบบ Point To Point หรือแบบที่มีเพียงเส้นทางเดียวในการเชื่อมต่อระหว่างกัน ไม่ต้องใช้ โปรโตคอลเลือกเส้นทาง เพราะจะทำให้เกิด Delay และปัญหาความล่าช้าอื่นๆมากมาย ควรใช้การวิธีการที่เรียกว่า Static Route จะดีกว่า โดยกำหนดเส้นทางในการนำส่ง Packet ที่ตายตัวให้กับ Router ซึ่งจะได้ประโยชน์ ไม่ว่าจะเป็นเรื่องความเร็ว ปัญหาเกี่ยวกับความปลอดภัยของข้อมูล และอื่นๆ

ความตั้งใจของผู้เขียนในฉบับนี้ จะขอกล่าวถึง การติดตั้ง Router ให้ทำงานบนโปรโตคอลเลือกเส้นทางเท่านั้น ดังนั้นต่อนี้ไปจะได้กล่าวถึง โปรโตคอลเลือกเส้นทางต่างๆ

กลับด้านบน

โปรโตคอลเลือกเส้นทางคืออะไร ?

เมื่อหัวใจหลักของ Router คือการเลือกเส้นทางที่ดีที่สุด ดังนั้นผู้ที่มอบประสิทธิภาพนี้ให้แก่ Router ก็คือ โปรโตคอลเลือกเส้นทาง อันเป็นวิถีทางในการคำนวณและจัดหาเส้นทาง ที่ดีที่สุด ที่เร็วที่สุด ไปสู่ปลายทางในรูปแบบของ Software ที่ฝังตัวอยู่ใน Router สำหรับ Router จาก Cisco ตัวโปรโตคอลนี้มาจากระบบปฏิบัติการ I/O ของ Cisco หรือ IOS ภายใต้ IOS Version ต่างๆ Router จะมีความสามารถในการใช้โปรโตคอลเลือกเส้นทางที่แตกต่างกันออกไป โดยโปรโตคอลเลือกเส้นทาง จะสั่งการให้ Router ทำกิจกรรมเบื้องต้น ในทันทีที่ Router เริ่มทำงาน และโปรโตคอลเลือกเส้นทางได้รับการจัดตั้งขึ้นเรียบร้อย กิจกรรมเบื้องต้นในที่นี้ได้แก่ การส่งข้อมูลข่าวสารชิ้นเล็กๆ ออกไปที่ Router เพื่อนบ้าน ในลักษณะ ทักทายกัน เพื่อให้ได้ข้อมูลมา อย่างน้อย 3 ประการ ได้แก่

  •  ความมีตัวตนในขณะนั้นของ Router เพื่อนบ้าน โดยจะได้รับการตอบรับหาก มีตัวตน
  •  ระยะทางความห่าง ในรูปแบบของ Delay หรือ จำนวนครั้งที่จะโดดข้าม
  •  Port ที่สามารถเข้าถึง Router เพื่อนบ้าน เป็นพอร์ตใดบ้าง

หลังจากที่ได้ข้อมูลมาแล้ว Router จะทำการ ปรับแต่ง หรือจัดสร้างตารางเลือกเส้นทางหรือ Routing Table ขึ้น จากนั้น จะนำข้อมูลนี้ ส่งออกไปให้ Router เพื่อนบ้าน เพื่อให้ Router เพื่อนบ้านนี้ นำไปปรับปรุงตารางเส้นทางของตนเองต่อไป กิจกรรมแบบนี้ จะเกิดขึ้นซ้ำแล้วซ้ำอีก เป็นห้วงเวลาที่แน่นอน ซึ่ง Router ที่เชื่อมต่อกันโดยตรง จะใช้กิจกรรมในลักษณะนี้ ต่อกัน ตามการชี้นำของโปรโตคอลเลือกเส้นทาง

อย่างไรก็ดี โปรโตคอลเลือกเส้นทาง สามารถแบ่งออกเป็นระดับชั้น (Class) ใหญ่ ได้ 2 แบบ ดังนี้

  •  ระดับขั้น Interior Domain หรือ Intra-Domain Routing Protocol 
  •  ระดับขั้น Exterior หรือ Inter Domain Gateway Routing Protocol

Interior Domain Routing Protocol

สามารถแบ่งออกเป็น 2 ประเภท ดังนี้

  •  Distance Vector ซึ่งเป็น Routing Protocol ที่อาศัยหลักเกณฑ์ในเรื่องระยะทางเป็นตัวกำหนด
  •  Link State ซึ่งอาศัยสถานะ การเชื่อมต่อเป็นตัวกำหนด

Distance Vector Routing Protocol

เป็นโปรโตคอลเลือกเส้นทางที่อาศัย ระยะทางเป็นตัวกำหนด โดยระยะทางในที่นี้ หมายถึง ปัจจัย ดังต่อนี้

  •  จำนวนของ Hop : Router จะเลือกเส้นทางที่ใช้เพื่อการเดินทางไปสู่ที่สั้นที่สุด โดยมีจำนวนครั้งการก้าวกระโดด น้อยที่สุด เช่น หากท่านเป็น Router ท่านคงไม่เลือกเส้นทางที่จะไปสู่ปลายทาง ที่ห่างออกไป 5 ป้ายรถเมล์ ขณะที่ท่านสามารถเลือกเส้นทางที่ห่างออกไปเพียง 2 ป้ายรถเมล์ (ความแตกต่างในเชิงเปรียบเทียบป้ายรถเมล์ในที่นี้ หมายถึง หากมีป้ายรถเมล์มาก จำนวนครั้งของการจอดก็ยิ่งมาก และแน่นอน ค่า Delay ก็ต้องเพิ่มมากขึ้น เช่นกัน)
  •  ค่า Bandwidth : Router จะเลือกเส้นทางที่ดีที่สุด โดยถือว่า เส้นทางใดที่มีค่า Bandwidth ซึ่งในที่นี้ คือความเร็วของช่องสัญญาณ เช่น Router จะเลือกเส้นทาง ที่มี Bandwidth 128K มากกว่าที่จะเลือกเส้นทางขนาด 64K อย่างแน่นอน
  •  ค่า Delay : Router จะทราบว่า ค่า Delay ของเส้นทางแต่ละเส้น ที่เชื่อมต่อกันมีมากน้อยสักเพียงใด โดยอาศัย การส่งข่าวสารไปทักทายกัน แล้วรอคอยคำตอบ ระยะเวลาของการรอคอย ก็คือค่า Delay ที่เกิดขึ้น ที่ Router รับรู้ แล้วนำค่านี้มาทำการคำนวณ ต่อไป
  •  ค่า Load : ค่า Load ในที่นี้หมายถึง น้ำหนักของกระแสข้อมูลข่าวสารที่ไหลอยู่บนเส้นนี้ ในแต่ละวินาทีที่ผ่านไป หากเปรียบเทียบกับความเป็นจริงในปัจจุบันแล้ว ท่านคงไม่เลือกขับรถไปในเส้นทางที่มีการจราจร ติดขัด หรือจอแจอย่างแน่นอน ถึงแม้จะอยู่ใกล้กว่าก็ตาม
  •  ค่าความน่าเชื่อถือ (Reliability) ค่าความน่าเชื่อถือนี้ หมายถึงค่าที่แสดง จำนวนครั้งที่เอาแน่นอนไม่ได้กับเส้นทาง โดยเฉพาะเส้นทางที่มีประวัติล่มบ่อยๆ
  •  ค่า MTU : เป็นค่าที่แสดงขนาดของ Packet ที่ใช้เดินทางบนเส้นทางนั้น ค่าสูงสุดคือไม่เกิน 1500 ไบต์ หากเปรียบเทียบกับชีวิตจริง ก็เปรียบได้กับ เส้นทางที่ถูกกำหนดว่า สามารถบรรทุกของได้หนักประมาณกี่ตัน แน่นอน หากท่านเป็นผู้ขนส่งสินค้า ท่านคงไม่เลือกขับบนเส้นทางที่กำหนดให้สามารถบรรทุกน้ำหนักที่ต่ำ

ที่กล่าวมานี้ เป็นส่วนหนึ่งที่โปรโตคอลเลือกเส้นทางแบบต่างๆ สั่งให้ Router ทำ โดยโปรโตคอลเลือกเส้นทางบางตัวอาจใช้ จำนวนของ Hop เป็นหลักเกณฑ์ ขณะที่บางตัวอาศัย Bandwidth หรือค่า Delay และ Load อย่างใดอย่างหนึ่ง ขณะที่โปรโตคอลเลือกเส้นทางบางตัวอาจใช้ ทั้ง Bandwidth และค่า Delay แบบผสมผสานกัน ในการคำนวณ ทำให้สามารถตัดสินใจได้ดีขึ้น ทำงานเร็วและแม่นยำขึ้น

ข้อเสียของ Distance Vector ได้แก่ การที่ Router จะต้องมีการส่งข่าวสารเพื่อหยั่งดู ความมีตัวตนของ Router เพื่อนบ้าน รวมทั้งการปรับปรุงตารางเส้นทางของตนเอง และให้แก่เพื่อนบ้าน อย่างสม่ำเสมอตรงเวลานี่เอง ที่ทำให้ Router ที่ใช้โปรโตคอลเลือกเส้นทางต้องทำงานหนักกว่า Router ที่ถูกกำหนดให้ทำงานแบบ Static Route อีกทั้งยังทำให้ Bandwidth ส่วนหนึ่งของช่องสัญญาณถูกเจียดออกไปใช้งานที่ไม่ใช่เพื่อการส่งข้อมูลจริง

ตัวอย่างของ โปรโตคอลเลือกเส้นทางแบบ Distance Vector ได้แก่ RIP Version 1 และ 2 IGRP และ EIGRP ของ Cisco เป็นต้น

โปรโตคอลแบบ Link State

โปรโตคอลเลือกเส้นทางแบบ Link State อาศัยสถานะ การเชื่อมต่อระหว่าง Router เป็นหลักเกณฑ์ ในการตัดสินใจเลือกเส้นทาง โดย จะมีการส่งข่าวสารในลักษณะทักทายกันออกไป เพื่อตรวจสอบหรือหยั่งดูความมีตัวตนของ Router เพื่อนบ้าน เมื่อใดที่ไม่ปรากฏการตอบรับของ Router เพื่อนบ้าน มันจะรีบปรับปรุงตารางเลือกเส้นทางของตนเอง จากนั้นจะรีบประกาศให้ Router ทุกตัวบนเครือข่าย หรือกลุ่มของ Router ตัวแทนที่เชื่อมต่อระหว่างกันทราบ ดังนั้น การเปลี่ยนแปลงใดๆ ที่เกิดขึ้นบนเครือข่าย Router ทุกตัวจะได้รับข่าวสาร ที่ทันเหตุการณ์

โปรโตคอลแบบ Link State มีประสิทธิภาพในการทำงานที่ดีกว่า Distance Vector ตรงที่ การปรับปรุง ตารางเส้นทางของ Router แต่ละตัวจะเกิดขึ้น ก็ต่อเมื่อมีการเปลี่ยนแปลงเกิดขึ้น เท่านั้น และหากมีการเปลี่ยนแปลงเกิดขึ้นจริง การปรับปรุงตารางเส้นทางก็เป็นเพียงบางส่วนที่เปลี่ยนแปลงจริงเท่านั้น เปรียบเทียบกับ Distance Vector ที่มีการปรับปรุงเป็นห้วงเวลาที่แน่นอน อีกทั้งการปรับปรุงที่เกิดขึ้น เป็นการปรับปรุงใหม่หมดทั้งตาราง ในลักษณะทำสำเนาทับทั้งตาราง ซึ่งทำให้ การปรับปรุงแต่ละครั้ง มีการใช้ Bandwidth ของเส้นทางค่อนข้างมาก

Inter-Domain Gateway Routing Protocol

เป็น โปรโตคอลเลือกเส้นทาง ที่นำมาใช้เพื่อเชื่อมกลุ่มของ Router จำนวนมากหลายๆกลุ่มเข้าด้วยกัน โดยมี Router อยู่ หนึ่งตัว หรือ มากกว่านั้น ที่เป็นตัวแทนของ Router ทั้งกลุ่ม เพื่อเชื่อมต่อกับ Router อีกกลุ่มหรือหลายๆกลุ่มเข้าด้วยกัน โดย Router ตัวแทนจะใช้ โปรโตคอลเลือกเส้นทาง ที่มีวิธีการเลือกเส้นทางที่แตกต่างออกไปจากที่ได้กล่าวมาแล้วทั้งหมด ตัวอย่างของ โปรโตคอลเลือกเส้นทางแบบนี้ ได้แก่ BGP ซึ่งบรรดา ISP ทั้งหลาย ต่างก็นำมาใช้เพื่อเชื่อมเครือข่ายเข้ากับ อินเตอรเนต หรือระหว่างกัน รายละเอียดการทำงานของ BGP จะได้กล่าวถึงในโอกาสต่อไป

กลับด้านบน

รู้จักกับ Routing Information Protocol (RIP)

Routing Information Protocol หรือ RIP เป็นโปรโตคอลเลือกเส้นทางประเภท Distance Vector ที่ถูกออกแบบมาให้ใช้กับเครือข่ายขนาด เล็กไปจนถึงขนาดกลาง เป็นโปรโตคอลเลือกเส้นทางมาตรฐานที่ไม่ขึ้นอยู่กับผู้ผลิตรายใด โดยมี RIP Version 1 ที่ได้รับมาตรฐาน RFC 1058

RIP เป็นโปรโตคอลที่เรียบง่าย อีกทั้งยังง่ายต่อการจัดตั้ง แต่ความเรียบง่ายของมัน กลับซ่อนปัญหาที่น่ากลัวไว้อยู่เบื้องหลัง

คุณลักษณะการทำงานของ RIP

คุณลักษณะของ RIP มีดังต่อไปนี้

  •  RIP อาศัย ค่าของจำนวน Hop เป็นหลัก เพื่อการเลือกเส้นทาง โดยจำกัดที่ไม่เกิน 15 Hop
  •  RIP จะส่งข่าวสารเกี่ยวกับการปรับปรุงเส้นทางออกไปทุก 30 วินาที
  •  การส่งข้อมูลเกี่ยวกับการปรับปรุงตารางเส้นทาง เป็นการส่งออกไปทั้งหมดของตารางทั้งที่เป็นของเก่าและของใหม่
  •  การส่งข่าวสารเกี่ยวกับการปรับปรุงเส้นทาง จะเกิดขึ้นกับ Router ที่เชื่อมต่อกันโดยตรงเท่านั้น

การทำงานขั้นพื้นฐานของ RIP Version 1

การทำงานขั้นพื้นฐานของ RIP ค่อนข้างเรียบง่าย ภายใต้กฎกติกา ดังนี้

  •  เมื่อใดที่ มีการ Boot Router ขึ้น เส้นทางที่ Router จะต้องให้ความสนใจเป็นลำดับแรกได้แก่ เส้นทางที่เชื่อมต่อกับ เครือข่ายปลายทางโดยตรง
  •  ภายใต้ RIP Version 1 ตัว Router จะทำการ แพร่กระจายข่าวสารเกี่ยวกับเครือข่ายที่มันรู้จักไปทั่วเครือข่ายทุกเครือข่าย ที่เชื่อมต่อกับมันโดยตรง
  •  Router ที่ทำงานภายใต้ RIP จะรับฟังการแพร่ข่าวสารนี้ โดยข่าวสารที่ใช้แพร่กระจายไปทั่ว (Broadcast) นี้ เป็นข่าวสารเพื่อการปรับปรุงเส้นทาง รวมทั้งการแสดงตัวตนของ Router
  •  การรับฟังการแพร่ข่าวสารไปทั่วของ Router เพื่อนบ้าน จะทำให้ Router ที่กำลังรับฟังอยู่ สามารถล่วงรู้เส้นทาง ไปสู่เครือข่าย อื่นๆ ที่ตนเองไม่รู้มาก่อน
  •  RIP ใช้ค่า Metric ประเภท Hop โดยอาศัยค่าที่แสดงจำนวน Hop เป็นหลักเกณฑ์ เพื่อเลือกเส้นทาง โดยมีค่าของ Hop จำกัดอยู่ที่ 15 หมายความว่า จำนวนของ Hop ที่ Router นับได้ต้องไม่เกิน 15 (15 Router ตลอดเส้นทางที่จะเดินทางผ่าน) ส่วน Hop ที่ 16 จะไม่สามารถเดินทางไปถึง
  •  หาก Router ตัวหนึ่ง เช่น Router A มีการส่งข้อมูลเกี่ยวกับการปรับปรุงเส้นทาง ไปที่ Router B และ Router B จะสมมติว่า Hop ต่อไปของ ของเครือข่าย ที่ Router จะปรับปรุง ได้แก่ Router A พูดง่ายๆก็คือ Router ที่เชื่อมต่อระหว่างกัน จะถือว่า ต่างก็เป็น Hop หนึ่งในตารางเส้นทางของตนเอง
  •  การส่งข้อมูลเกี่ยวกับการปรับปรุงเส้นทางระหว่าง Router จะกระทำเป็นห้วงเวลาที่แน่นอน

รูปที่ 12 แสดงการใช้ค่า Metric ของ RIP

รูปที่ 13 แสดงการนับจำนวน Hop ของ RIP

จากรูปที่ 12 จะเห็นว่า Router C เชื่อมต่อโดยตรงกับ Network C เมื่อใดที่ Router C ประกาศเส้นทางไปที่ Router B ค่า Metric ของมันจะเพิ่มขึ้น 1 ค่า เช่นเดียวกันที่ Router B จะเพิ่มค่า Metric เป็น 2 และประกาศเส้นทางไปที่ Router A จากมุมมองของ Router C Router A และ B จะถูกมองเป็น 2 Hop

จำนวนของ Hop ที่ใช้เดินทางไปสู่ปลายทาง หมายถึง จำนวนของ Router ที่ Packet จะต้องเดินทางผ่าน ไปสู่เครือข่ายปลายทาง อย่างไรก็ดี การนับจำนวน Hop เป็นหลักเพื่อเลือกเส้นทางเดินที่ดีที่สุด ไม่ได้หมายความว่า Router จะได้เส้นทางที่ดีที่สุด เสมอไป ตัวอย่าง เช่น เพื่อให้ Router A เดินทางไปสู่ Router B ตัว RIP จะเลือกเส้นทางการเชื่อมต่อความเร็ว 56K แทนที่จะเลือก เส้นทางความเร็วสูงกว่า อย่าง เช่น 1.5 Mbps เนื่องจากว่า Router A เห็นว่า การเดินทางไปสู่ B โดยผ่าน Router C เป็นการใช้ 2 Hop โดยไม่สนใจว่า การเดินทางอ้อมผ่านทาง Router C จะมีความรวดเร็วกว่า

รูปที่ 14 แสดงการเกิดปัญหา Routing Loop

กลับด้านบน

การเกิดปัญหา Routing Loop

RIP เป็นตัวอย่างของปัญหาที่เกิดขึ้นบน โปรโตคอลเลือกเส้นทางอย่าง Distance Vector ปัญหาของ Router ที่ทำงานภายใต้ RIP คือการที่ Router ไม่สามารถมองเห็นหรือเข้าใจภาพรวมของเครือข่ายทั้งหมด แต่จะอาศัยข้อมูลข่าวสารที่ได้ รับจาก Router เพื่อนบ้าน ว่า มี Router อยู่กี่ตัว และเชื่อมต่อที่ใดบ้าง ด้วยเหตุนี้ เมื่อใดที่เกิดการเปลี่ยนแปลงเกิดขึ้นบนเครือข่าย Router จะไม่ได้รับการปรับปรุงข่าวสารนี้ ได้พร้อมกันทุกตัว ทำให้ได้รับข้อมูลข่าวสารล่าช้า ทำให้ Router บางตัว หรือส่วนใหญ่ยังเข้าใจว่า การเปลี่ยนแปลงบนเครือข่ายยังไม่เกิดขึ้น ทั้งที่ มีบางเครือข่าย ได้ล่มไปก่อนหน้านี้แล้ว Router เหล่านี้ ก็ยังปรับปรุงข้อมูลเกี่ยวกับเส้นทางเก่า ให้แก่กัน ทำให้เกิดปัญหาที่เรียกว่า Routing Loop โดย Routing Loop เป็นเรื่องของ Packet ที่วิ่งกลับไปกลับมาระหว่าง Router 2 ตัวหรือมากกว่า โดยไม่สามารถหลุดออกไปจากวงจรสะท้อนกลับไปกลับมานี้ได้ บางครั้งฝรั่งเรียกลักษณะนี้ว่า Count to Infinity

เพื่อหลีกเลี่ยงปัญหานี้ RIP จะใช้กลไกการทำงานหลายประการ ดังนี้

  •  Count To Infinity
  •  Split Horizon
  •  Poison Reverse Update
  •  Hold Down Counter
  •  Triggered Updates

ปัญหา Count To Infinity

RIP จะยอมให้มีจำนวนของ Hop ทั้งหมดบนเส้นทางไม่เกิน 15 Hop เครือข่ายใดที่อยู่บนเส้นทางที่มีจำนวน Hop มากกว่า 15 Hop จะไม่สามารถไปถึงได้ ต่อนี้ เรามาดูว่า Count To Infinity ทำงานอย่างไร จากภาพตัวอย่าง 13 ดังต่อไปนี้

1. สมมติว่า Router A สูญเสียการติดต่อกับเครือข่าย A ทำให้มีการสร้าง Triggered Update ขึ้น (Triggered Update หมายถึงการปรับปรุงตารางเส้นทางทันที โดยไม่ต้องรอให้ถึงคิวหรือถึงเวลาการปรับปรุงเสียก่อน) Router A จะส่งการปรับปรุงนี้ ให้แก่ Router B และ Router C โดยภายใน Triggered Update ในครั้งนี้ เป็นการบอกให้ Router B และ C ได้รับรู้ข้อเท็จจริงว่า Router สูญเสียการติดต่อกับเครือข่าย A ไปแล้ว แต่ ข้อมูลที่ปรับปรุงนี้ จะมี Delay เกิดขึ้นระหว่างที่เดินทางไปสู่ Router B (อาจเกิดจาก CPU ของ Router กำลังยุ่ง หรือการจราจรบนเส้นทางการเชื่อมต่อกำลังติดขัด) แต่ ขณะเดียวกัน ข่าวสารที่ปรับปรุงนี้ อาจไปถึง Router C ก่อน (เนื่องจากเส้นทางโล่ง) เมื่อ Router C ได้รับข้อมูลการปรับปรุงเส้นทางแล้ว ก็รีบแก้ไขตารางเส้นทางทันที โดยเคลียร์ค่า เกี่ยวกับ เส้นทางที่จะเดินทางไปที่ เครือข่าย A ออกไปจากตาราง

2. ขณะที่ Router B ยังไม่ได้รับข่าวสารการปรับปรุงเส้นทางนี้ จาก Router A มันจะส่ง ข่าวสารเกี่ยวกับเส้นทาง อันเป็นของเก่า ออกไปที่ แสดงว่า เครือข่าย A ยังมีตัวตน ออกไป ด้วยจำนวน Hop ที่นับได้คือ 2 และเมื่อ Router C ได้รับการปรับปรุงเส้นทาง Router B อันเป็นของเก่าแล้ว ก็จะเข้าใจว่า นี่เป็นเส้นทางใหม่ที่จะเดินทางไปสู่เครือข่าย (ซึ่งบัดนี้ ยังป่วยอยู่)

3. Router C เมื่อได้รับการปรับปรุงด้วยข้อมูลข่าวสารจาก Router B แล้ว Router C จะส่งข้อมูลที่ปรับปรุงนี้ ออกไปที่ เครือข่าย A ด้วยค่า Hop ที่นับได้คือ 3

4. เมื่อ Router A ได้รับข่าวสารอันเป็นเท็จนี้แล้ว ก็จะส่งข่าวสารที่ปรับปรุงแล้วนี้ ออกไปที่ Router B เพื่อบอกว่า มันสามารถเข้าถึง เครือข่าย A ด้วยจำนวน Hop มีค่าเป็น 4

5. การวนไปมาของข่าวสารที่ใช้ปรับปรุงตารางเส้นทางนี้ จะเกิดขึ้นอย่างไม่จบสิ้นง่ายๆ จนกว่าจะไปถึงค่า Hop 16 ซึ่งเราเรียกว่า Infinity หรืออนันต์ มันจะประกาศว่า Hop สุดท้ายเป็นอันถูกยกเลิก และเพิกถอนออกจากตาราง เส้นทาง

ปัญหา Split-Horizon

กฎของ Split Horizon ระบุไว้อย่างชัดเจนว่า Router จะต้องไม่ประกาศเส้นทาง กลับไปยัง Router ที่ส่งตารางปรับปรุงมาให้ หมายความว่า Router จะต้องไม่เอาข้อมูลที่ได้รับจาก Router ต้นทาง ส่งกลับไปให้ Router ต้นทาง เช่นกัน ตัวอย่าง เช่น Router A ได้รับการปรับปรุงข้อมูลจาก Router B และ Router A นำข้อมูลปรับปรุงนี้ ส่งต่อไปให้กับ Router C หากมีการใช้ Split Horizon แล้ว Router C จะไม่มีวันที่จะเอาข้อมูลปรับปรุง ส่งไปให้กับ Router B อันเป็นต้นทาง ในกรณีที่มีการเชื่อมต่อกันเป็น Loop แบบรูปที่ 14

Cisco Router ได้ถูกกำหนดให้ใช้ Split Horizon โดยปริยาย แต่ในบางกรณี ท่านอาจต้อง ยกเลิกการใช้ Split Horizon เนื่องจาก หากมีการเชื่อมต่อ เครือข่ายในรูปแบบ Hub and Spoke อีกทั้ง เป็นการสื่อสารแบบ Non-Broadcast Multiple Access (NBMA) อย่างเช่น การเชื่อมต่อผ่าน Frame Relay เป็นต้น

รูปที่ 15 แสดงการใช้งาน Split Horizon

จากรูปที่ 15 จะเห็นว่า Router B เชื่อมต่อกับ Router A ผ่านทาง Frame Relay และเส้นทางทั้งสองที่เรียกว่า PVC (Permanent Virtual Circuit) มีจุดสิ้นสุดที่ปลายทั้งสองด้าน ของ Serial Port ของ Router B

ถ้าหากว่า ไม่มีการเพิกถอนการใช้งาน Split Horizon บน Serial Port ของ Router B แล้ว ตัว Router C จะไม่ได้รับข่าวสารเกี่ยวกับการปรับปรุงเส้นทางจาก Router A อย่างแน่นอน

ปัญหา Poison Reverse

Poison Reverse มีการทำงานที่คล้ายคลึงกับ Split Horizon โดยอาจทำงานร่วมกัน โดยมีชื่อเรียกว่า Split Horizon With Poison Reverse โดยการทำงานร่วมกันนี้ จะทำให้มีตารางเส้นทางที่เหมือนกัน แต่จะตั้งค่า Metric ให้เป็นค่า Infinity หรือ 16

การตั้งค่าเป็น Infinity และประกาศค่าของเส้นทางปรับปรุงแบบย้อนกลับอย่างรวดเร็ว อาจทำให้กระบวนการของ Loop ถูกตัดขาด มิเช่นนั้นกลับทำให้ ค่าของเส้นทางที่ไม่ถูกต้อง ถุกจัดเก็บไว้ในตารางเส้นทางจนกว่า จะถึงเวลาขจัดมันออกไป

จุดด้อยของการใช้ Poison Reverse คือทำให้ตารางเส้นทางมีขนาดใหญ่เกินความจำเป็น

ปัญหา Hold Downs

RIP มีตัวตั้งเวลาอยู่ตัวหนึ่ง เรียกว่า Hold Down Timer เป็นตัวตั้งเวลาที่ มีไว้เพื่อป้องกันมิให้ Router ทำการรับข้อมูลข่าวสารเกี่ยวกับเส้นทางในช่วงเวลาสั้นๆ หลังจากที่เพิ่งได้เคลียร์เส้นทางที่เปลี่ยนแปลงแล้วออกจากตาราง แนวคิดการใช้ Hold Down คือการทำให้แน่ใจว่า Router ทุกตัวได้รับข่าวสารเกี่ยวกับเส้นทาง ให้เรียบร้อย เสียก่อน อย่าเพิ่งทำการส่งข่าวสารเกี่ยวกับเส้นทางที่ไม่ถูกต้องออกมา

จากรูปที่ 14 จะเห็นว่า Router B ได้ประกาศข่าวสารเกี่ยวกับเส้นทางที่ปรับปรุงออกมา ซึ่งเป็นข่าวสารที่ไม่ถูกต้อง ไปยัง Router C โดยมีสาเหตุมาจาก ความล่าช้าในการปรับปรุงตารางเส้นทางแก่ Router C แต่ด้วยการใช้ Hold Down Timer เหตุการณ์นี้จะไม่เกิดขึ้นอย่างแน่นอน เนื่องจาก Router C จะยังไม่ยอมรับข้อมูลตารางเส้นทางที่เกี่ยวกับ เครือข่าย A ประมาณ 180 วินาที

ปัญหา Hold Downs

RIP มีตัวตั้งเวลาอยู่ตัวหนึ่ง เรียกว่า Hold Down Timer เป็นตัวตั้งเวลาที่ มีไว้เพื่อป้องกันมิให้ Router ทำการรับข้อมูลข่าวสารเกี่ยวกับเส้นทางในช่วงเวลาสั้นๆ หลังจากที่เพิ่งได้เคลียร์เส้นทางที่เปลี่ยนแปลงแล้วออกจากตาราง แนวคิดการใช้ Hold Down คือการทำให้แน่ใจว่า Router ทุกตัวได้รับข่าวสารเกี่ยวกับเส้นทาง ให้เรียบร้อย เสียก่อน อย่าเพิ่งทำการส่งข่าวสารเกี่ยวกับเส้นทางที่ไม่ถูกต้องออกมา

จากรูปที่ 14 จะเห็นว่า Router B ได้ประกาศข่าวสารเกี่ยวกับเส้นทางที่ปรับปรุงออกมา ซึ่งเป็นข่าวสารที่ไม่ถูกต้อง ไปยัง Router C โดยมีสาเหตุมาจาก ความล่าช้าในการปรับปรุงตารางเส้นทางแก่ Router C แต่ด้วยการใช้ Hold Down Timer เหตุการณ์นี้จะไม่เกิดขึ้นอย่างแน่นอน เนื่องจาก Router C จะยังไม่ยอมรับข้อมูลตารางเส้นทางที่เกี่ยวกับ เครือข่าย A ประมาณ 180 วินาที0000

กลับด้านบน

การติดตั้งและจัด Configure RIP ขั้นพื้นฐาน

รูปที่ 16 ตัวอย่างการเชื่อมต่อ Router ภายใต้ RIP พื้นฐาน

การติดตั้ง RIP ที่ Router A

Current configuration:

! version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname RouterA

!

interface Loopback0 <------------- เป็น Address สมมตเพื่อใช้ทดสอบการทำงาน เท่านั้น

ip address 10.1.1.1 255.255.255.0

!

interface Ethernet0 <-------------ใช้คำสั่งเรียก Port Ethernet 0 ออกมาใช้งาน

ip address 148.1.1.1 255.255.255.0 <------------ใส่ IP Address ให้กับ Ethernet Port

no keepalive <--------------ในกรณีที่ Ethernet Port ของ Router ไม่ได้เชื่อมต่อกับ Hub จริงให้ใช้คำสั่งนี้เพื่อมิ ให้ Router คอยตรวจสอบ Hub

!

interface Serial0

ip address 192.1.1.1 255.255.255.0

!

router rip <---------------เป็นคำสั่งที่เรียกโปรโตคอล RIP ออกมาใช้งานบน Router

network 10.0.0.0 <------------ เป็นประกาศให้ Router อื่นรู้ว่า Router ดูแล IP Address 10.0.0.0

network 148.1.0.0 <------------- เป็นประกาศให้ Router อื่นรู้ว่า Router นี้ ดูแลเครือข่าย 148.1.0.0

network 192.1.1.0 <------------- เป็นประกาศให้ Router อื่นรู้ว่า Router นี้ มีเส้นทางเชื่อมต่อด้วยเลขหมาย เครือข่าย 192.1.1.0

!

no ip classless

!

line con 0

line aux 0

line vty 0 4

  login

!

end

การติดตั้ง RIP ที่ Router B

version 11.2

service udp-small-servers

service tcp-small-servers

!

hostname RouterB <--------กำหนดชื่อของ Router

!

interface Ethernet0

no ip address <------------ เนื่องจาก Router B ไม่ได้เชื่อมต่อกับ Ethernet LAN ดังนั้นไม่ต้องใส่ Address

shutdown <--------------- สั่งให้ปิด Ethernet Port เพื่อไม่ต้องใช้งาน และไม่ต้องให้ตรวจสอบ Port

!

interface Serial0 <--------- คำสั่งเรียก Serial Port 0 ออกมาใช้งาน

ip address 192.1.1.2 255.255.255.0 <---------กำหนด ค่า IP Address ให้กับ Serial Port no fair-queue

clockrate 500000 <-----------กำหนด Clockrate ให้กับ Serial Port 0

!

interface Serial1 <--------- เรียก Serial Port 1 ออกมาใช้งาน

ip address 193.1.1.2 255.255.255.0 <---------กำหนด IP Address ให้กับ Serial Port 1

clockrate 500000 <---------กำหนดความเร็ว ในรูปของสัญญาณนาฬิกาให้กับ Serial Port 1

!

router rip <---------- เรียก โปรโตคอล RIP ออกมาใช้งาน

network 192.1.1.0 <---------- ประกาศให้รู้ว่า Router B เชื่อมต่อกับ Router A บนเส้นทาง 192.1.1.0

network 193.1.1.0 <----------- ประกาศให้รู้ว่า Router B เชื่อมต่อกับ Router C บนเส้นทาง 193.1.1.0

!

!

line con 0

line aux 0

line vty 0 4

  login

การติดตั้ง RIP ที่ Router C

version 11.2

service udp-small-servers

service tcp-small-servers

!

hostname RouterC

!

interface Ethernet0 <-------- เนื่องจาก Routerนี้เชื่อมต่อกับ Ethernet Port 0 จึงต้องเรียกออกมาใช้งาน

ip address 152.1.1.1 255.255.255.0 <------ กำหนด IP Address ให้กับ Ethernet Port 0 no keepalive

!

!

interface Serial0 <----------- เรียก Serial Port 0 ออกมาใช้งาน

ip address 193.1.1.1 255.255.255.0 <-----------กำหนด IP address ให้กับ Serial Port 0

!

router rip <------- เรียกโปรโตคอล RIP ออกมาใช้งาน

network 152.1.0.0 <-------- ประกาศให้ Router อื่นรู้ว่า Router นี้ดูแลเครือข่าย 152.1.1.0

network 193.1.1.0 <-------- ประกาศให้ Router อื่นรู้ว่า เส้นทางที่จะเข้าสู่ Router นี้อยู่ที่เบอร์ IP ใด

!

no ip classless

!

!

line con 0

line aux 0

line vty 0 4

  login

!

end

หมายเหตุ : ตัวอักษรสีดำหนา หมายถึงคำสั่งที่จะต้องป้อนเข้าไปที่ Router

หลังจากที่ติดตั้งเสร็จแล้ว ท่านสามารถเรียกดู การทำงานของ RIP ด้วยคำสั่ง Show ip protocol ซึ่งจะปรากฏภาพหน้าจอ ดังนี้

รูปที่ 17 แสดงหน้าจอ หลังจากที่ใช้คำสั่ง Show ip protocol

คำสั่ง show ip protocol จะช่วยให้ท่านสามารถมองเห็นว่า ภายใน Router ขณะนั้น ได้มีการสร้างข้อมูลข่าวสารขึ้นมาอย่างไรบ้าง รวมทั้งแสดงสถานการณ์ทำงานของโปรโตคอล RIP รวมทั้ง Timer ต่างๆของมัน

ในกรณีที่ท่านต้องการดูว่า โปรโตคอล RIP ของ Router ที่เชื่อมต่อระหว่างกันทำงานอยู่หรือไม่ให้ใช้คำสั่ง Debug router rip ซึ่งจะได้ภาพ ปรากฏบนหน้าจอ ดังนี้

รูปที่ 18 แสดงหน้าจอ หลังจากใช้คำสั่ง debug ip rip

คำสั่ง Debug ip rip เป็นคำสั่งที่ใช้แสดงการสื่อสารระหว่าง Router ที่ทำงานภายใต้ RIP โดยจะแสดงการส่งข่าวสารที่เกี่ยวกับการปรับปรุงเส้นทางมาที่ Router รวมทั้งแสดงให้เห็นว่า Router ตัวนี้ ได้ส่ง ข่าวสารเกี่ยวกับเส้นทางออกไปอย่างใดบ้าง ประโยชน์ของการใช้คำสั่งนี้ คือท่านสามารถใช้เพื่อตรวจสอบดูปัญหาของ Router ที่เชื่อมต่อกัน เพื่อให้แน่ใจว่า โปรโตคอล RIP ทำงานไม่ผิดพลาด

ในกรณีที่ ท่านต้องการดูว่า Router ได้รับการปรับปรุงและสร้างตารางเลือกเส้นทาง ท่านสามารถใช้ คำสั่ง Show ip route ซึ่งจะทำให้ปรากฏ ภาพบนหน้าจอดังนี้

รูปที่ 19 แสดงหน้าจอหลังจากที่ใช้คำสั่ง Show ip Route

คำสั่ง Show ip route จะช่วยให้ท่าน ได้เห็นว่า Router ได้เรียนรู้อะไรเกี่ยวกับเส้นทางระหว่าง Router ปัจจุบันกับ Router เพื่อนบ้าน

กลับด้านบน

ส่งท้ายบทความ

เรื่องของเครือข่าย Router และการจัดตั้ง Router ภายใต้ Routing Protocol ต่างๆ ในฉบับนี้จำต้องอำลาท่านผู้อ่านไปก่อน ฉบับหน้า จะเป็นรายละเอียดวิธีการจัดตั้ง Router ภายใต้ RIP และ IGRP รวมทั้งวิธีการปรับแต่งเครือข่าย Router ให้มีประสิทธิภาพสูงสุด


กลับด้านบน

SE-ED.com /ไมโครคอมพิวเตอร์ /คอมพิวเตอร์ยูสเซอร์ /อินเทอร์เน็ต /อัพเดต /อินดัสเตรียล /เซมิคอนดักเตอร์ /ฮอบบี้ /แมคานิคอล

สงวนลิขสิทธิ์ พ.ศ. 2541- โดยบริษัท ซีเอ็ดยูเคชั่น จำกัด (มหาชน)

Copyright © 1998- by SE-EDUCATION Public Company Limited. All rights reserved.